GTA Aquarium Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
596 Posts
Discussion Starter · #1 ·
I woke up this morning to find my airline detached from the venturi on my powerhead. the temp had spiked in my tank to 84f

its a 125g tank. stocked with rare plecos and SA cichlids.
my parameters are good, I did a 30/40% water change the day before, like I always do once a week. I'm losing fish and plecos left right and centre at the moment. doing another water change, adding lots of oxygen to the tank.

any other advice? could it be an issue with the local water source?
 

·
Registered
Joined
·
596 Posts
Discussion Starter · #2 ·
60% water change, I've got every airstone/pump I own working on the tank. Things are turning around, less gasping only lost a couple fish so far
 

·
Registered
Joined
·
1,008 Posts
Have you checked the heater to see if its faulty, just the power head not working should not effect temps that much. Good luck.
 

·
Registered
Joined
·
203 Posts
Have you checked the heater to see if its faulty, just the power head not working should not effect temps that much. Good luck.
Agreed! Double check your heater and turn it down a bit.
 

·
Registered
Joined
·
596 Posts
Discussion Starter · #5 ·
should have mentioned, the heat issue was due in large part to my neighbours controlling the thermostat. they seem to enjoy living in a 90f apartment..... :( my heaters usually run at 76f

a few losses, alot more aeration and things are slowly getting back to normal
 

·
Registered
Joined
·
489 Posts
maybe add a marine fan to blow across the surface of the tank. You need to run open top if you don't already. If you are worried about jumpers check out how to make screens using BRS mesh. You can get small fans that blow across surface of the water which will help temps.
 
1 - 6 of 6 Posts
Top